Firmware Bip | MNVolkov BipOS (EN)

MNVolkov

Разработчик
Команда форума
Сообщения
209
Реакции
1,463
Баллы
223
Ваше "умное" устройство
Amazfit Bip
  • Первое сообщение
  • #1
MNVolkov BipOS
Custom firmware, based on latin FW 1.1.5.12 or 1.1.5.36 and not latin 1.1.2.05
for AmazFit Bip v.0.5


Unti--2.png

Author: MNVolkov (Maxim Volkov)​

Description:
Customized firmware for AmazFit Bip. The list of applications is called from the AliPay menu so you need to enable it in the MiFit settings. You can also enable the side menu (swipe right). Implemented two additional applications for your Bip:

Calculator: The calculator allows you to perform basic arithmetic operations + - * /. Deleting the last dialed digit, resetting and receiving an answer is called by clicking on the corresponding areas of the scoreboard, indicated by the inscriptions C = <-

Calendar : The algorithm for calculating the day of the week works for any date in the Gregorian calendar. The range of the calendar from 1600 to 3000 years.At startup, the current month is displayed, the current day is highlighted in color. There is ability to select another period through turning: swipe left-right to switch the months, swipe up and down - switch the years.

Editing of existing alarms: You can change the time of the existing alarm, set the repetition by day of the week, or select single mode (available by left swipe). To select a single mode, you must uncheck all the checkboxes. For convenience, you can set the current time by clicking on the alarm icon on the time setting screen. Synchronization with MiFit occurs only on/off state (as before), while the time in MiFit does not change. However, you can still set the alarm in MiFit and it will sync with the watch. The alarm time displayed om watch is always actual.

Flashlight: When start Flashlight the screen get white color and backlight turn up high.

One of this applicatoins can be selected for "quick" launch using "Left side function" in MOD menu. When it selected left swipe from dial launches "quick" app. MOD menu now accessible from Right menu (don`t forget to switch it ON by using Mi Fit)

This custom firmware is based on latin firmware on your choose 1.1.5.12, 1.1.5.36 or not latin 1.1.2.05 (Be careful when applying the patch, do not forget about the need to flash resources when changing versions in watch)

Watch photo:
calc_355.jpgcalend_0.3.jpgAlarm_555.jpgalarm_days.jpgapp_en_tn.pnglang (2).pngflash_en.jpgIMG_20190728_221907_0_tn.png

The firmware is available in two formats:
1. File for direct flasing with your favorite program (I use GadgetBridge)

2. Motorola S-Record file for applying a patch to your favorite firmware (for example, another mod of the same firmware version).
Patch can be applied strictly on latin firmware version 1.1.5.12 or 1.1.5.36. This patch should be applied on the specified firmwares. The only condition is the absence of AliPay menu modifications and alarms in the firmware, since My patch changes the code of the AliPay menu function and the alarm clock interface.


1. Unpack the patch.zip archive to a separate folder
2. Open this folder in a separate window
3. Copy patch (file with .mot extension) and the firmware you want to patch (the file with the extension .fw or .fw.latin) into a separate folder
4. Arrange Explorer windows so that you can see both of the above files folders.
5. Use the Ctrl key to select the patch file and the firmware on which the patch will be applied
6. Drag and drop both selected files onto patch_en.bat located in the next window (when hovering over patch_en.bat will be label " Open with patch_en.bat")
7. In the window that opens, make sure that the patch is applied, remember the name of the patched firmware. After reading, you can close.
8. The firmware file with the applied patch will be located in the same folder where the patch and firmware were dragged. It`s name starts with "patched..." and extension .fw or .fw.latin
9. Flash the patched firmware using up to date version GadgetBridge
10. Flash compatible resources and fonts if necessary.

Everything you do with your watch, you do at your own risk! No one except You is responsible for your actions!
No claim for "brick" your watch neither I nor anyone else takes!!!
Important


it is recommended to use the latest version of Gadget Bridge For firmware.
Application - Gadget Bridge 0.34.0

Feedback and suggestions can be sent to the PM.

Download here:
У вас нет разрешения на просмотр содержимого!


MNVolkov MOD 0.4.1
У вас нет разрешения на просмотр содержимого!


MNVolkov MOD v0.4
У вас нет разрешения на просмотр содержимого!


MNVolkov MOD v0.3.2 based on official firmware Latin 1.1.5.12
У вас нет разрешения на просмотр содержимого!


MNVolkov MOD v0.3.2 based on official firmware Latin 1.1.5.36
У вас нет разрешения на просмотр содержимого!

Support developers by making DONATION
У вас нет разрешения на просмотр содержимого!

 
Последнее редактирование:

walek75

Новичок
Сообщения
2
Реакции
1
Баллы
23
@MNVolkov Big thanks for your hard work. BipOs works like a charm.
BTW:
How to use dump memory feature ?
It's possible to dump by BT ?
Is it somethings like lite monitor/debuger ?
 

MNVolkov

Разработчик
Команда форума
Сообщения
209
Реакции
1,463
Баллы
223
Ваше "умное" устройство
Amazfit Bip
Mr. @MNVolkov, I'm using BipOS 5.0 with reaload files. In Compass menu, coordinates area are freezing in touch and backing only with fisical button.
Are you aware of this issue?
Thanks for your hard work.
I just tried on 1.1.5.36 compass has a normal behavior.
@MNVolkov Big thanks for your hard work. BipOs works like a charm.
BTW:
How to use dump memory feature ?
It's possible to dump by BT ?
Is it somethings like lite monitor/debuger ?
dump function just copy RAM to device log with ti-txt format

Пожалуйста войдите или зарегистрируйтесь для просмотра скрытого текста.


You can download log from device by using GadgetBridge and analysing it with HEX editor
 

404AccNotFound

Новичок
Сообщения
3
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
Hello, sorry for messaging twice. I am currently on V1.1.5.56.
How do I install this? Do I have to downgrade with an old version of Mi Fit?
I know how to install font, fw, etc. files using GadgetBridge, but do I need to downgrade to 1.1.2.05? (Non-latin, english)

Thank you! This is really cool!
 

LORD

Главный модератор
Команда форума
Сообщения
360
Реакции
279
Баллы
78
Ваше "умное" устройство
Amazfit Bip

dslul

Новичок
Сообщения
3
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
@MNVolkov How much space do we have for apps? The bip has on the inside a 8 MiB flash memory, do you think we could use it?
 

totalnoob43

Новичок
Сообщения
20
Реакции
10
Баллы
8
Ваше "умное" устройство
Amazfit Bip
Hello, sorry for messaging twice. I am currently on V1.1.5.56.
How do I install this? Do I have to downgrade with an old version of Mi Fit?
I know how to install font, fw, etc. files using GadgetBridge, but do I need to downgrade to 1.1.2.05? (Non-latin, english)

Thank you! This is really cool!
You go ahead and flash the files provided for the version you want. I believe you can just flash any recent fw over any other, even this custom one.
 

MNVolkov

Разработчик
Команда форума
Сообщения
209
Реакции
1,463
Баллы
223
Ваше "умное" устройство
Amazfit Bip
Последнее редактирование модератором:

ntelas

Новичок
Сообщения
2
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
Hi,

I don't understand what I have to do to get the English version of the BipOS firmware. I had the first version of the firmware (before bipOS) and it was all in English. I updated to the BipOS version and I can't make it to show English. It only shows Russian. I am not talking about the AliPay menu, that's in English, well the only English submenu I can find is when I am picking a language inside alipay. I am talking about the Bip's menu.

Thanks in advance.
 

Archon

Друг форума
Сообщения
263
Реакции
248
Баллы
63
Ваше "умное" устройство
Amazfit Bip
@ntelas, for now, English is available only in BipOS based on 1.1.2.05 stock non-latin firmware (and not on SantaX mod). So you should take 1.1.2.05 non-latin stock firmware (here) and patch it according to instructions.
 

ntelas

Новичок
Сообщения
2
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
@ntelas, English is available only in BipOS based on 1.1.2.05 stock non-latin firmware (and not on SantaX mod). So you should take 1.1.2.05 non-latin stock firmware (here) and patch it according to instructions.
Thank you, I will try that one. Thanks!
Сообщения автоматически объединены:

@ntelas, for now, English is available only in BipOS based on 1.1.2.05 stock non-latin firmware (and not on SantaX mod). So you should take 1.1.2.05 non-latin stock firmware (here) and patch it according to instructions.
Sorry for the double post but I can't edit my old one.

I flashed the rom you suggested me but it doesn't even have the AliPay apps. I don't know how to flash them even though I took a look into the instructions.
May I ask, is it possible to have the BipOS firmware with English language, or should I flash the old one I had before(pre BipOS)?
 
Последнее редактирование:

Pólux

Друг форума
Сообщения
7
Реакции
21
Баллы
8
Ваше "умное" устройство
Amazfit Bip
I flashed the rom you suggested me but it doesn't even have the AliPay apps. I don't know how to flash them even though I took a look into the instructions.
May I ask, is it possible to have the BipOS firmware with English language, or should I flash the old one I had before(pre BipOS)?
That was unpatched firmware. You must patch it or try already patched firmware (here). See inside "Stock_1.1.2.05.not_latin" folder.
 

Sparkinit

Новичок
Сообщения
3
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
Where are you finding the original firmware to use?
 

Sparkinit

Новичок
Сообщения
3
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
I ran the patch but don't think I got the right result. I have 3 files now:
Foo
MNVolkov_BipOS_0.5_Mili_chaohu.fw
patch_MNVolkov_BipOS_0.5_latin_1.1.5.36.mot

I am not sure which is the correct one that was patched and ready to go
 

Pólux

Друг форума
Сообщения
7
Реакции
21
Баллы
8
Ваше "умное" устройство
Amazfit Bip
I am not sure which is the correct one that was patched and ready to go
You don't need to patch if you don't want to. If you are looking for "ready to go" BipOS patched firmware in English, including BipOS apps (calculator, calendar, etc), the easiest way is to download "MNVolkov_BipOS_0.5.1_not_latin_1.1.2.05.zip" (here) and flash all three files (ft, res and fw) from folder "Stock_1.1.2.05.not_latin".

Download link taken from @MNVolkov 's original post here.
 

Sparkinit

Новичок
Сообщения
3
Реакции
0
Баллы
1
Ваше "умное" устройство
Amazfit Bip
You don't need to patch if you don't want to. If you are looking for "ready to go" BipOS patched firmware in English, including BipOS apps (calculator, calendar, etc), the easiest way is to download "MNVolkov_BipOS_0.5.1_not_latin_1.1.2.05.zip" (here) and flash all three files (ft, res and fw) from folder "Stock_1.1.2.05.not_latin".

Download link taken from @MNVolkov 's original post here.
Thanks Pólux - I thought I needed a Latin one. I thought Latin was the English. Thanks!! WIll try this!
 

Пользователи, просматривающие эту тему

Сейчас на форуме нет ни одного пользователя.
Сверху Снизу